Feedspring - Website - Unavailable – Incident details

Application experiencing major outage

Website - Unavailable

Resolved
Major outage
Started 6 months agoLasted 25 minutes

Affected

Website

Operational from 3:04 PM to 3:04 PM, Major outage from 3:04 PM to 3:29 PM, Operational from 3:29 PM to 3:29 PM

Updates
  • Resolved
    Resolved

    Website All services are now operational

  • Identified
    Identified

    Website We've been made aware of a possible service disruption. We will update you when we know more.